Help

Minimum requirements of your computer to play

These are the minimum requirements of your computer to play correctly:

Shockwave on Windows 64 bits.

On operating systems Windows of 64 bits, Shockwave is only compatible with browsers 32-bit.

For example, Windows 7 has two versions of Internet Explorer: one is 32-bit (by default version) and another is 64-bit. Shockwave only works on the version 32-bit.

More information

Related subjects

    Enough information?

    • Yes Great! Let’s play.
    • No I would like to contact customer service.

    Are you leaving yet?

    We want to improve your experience in the game, so it is necessary that you create an account and you can have your own profile, your avatar, your friends, your points...Are you sure you will miss it?

    Create a new account